summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-08-07 09:58:58 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-08-29 12:00:03 +0200
commit4a4b74c22032a3f07305e8631d40942505e9e9d4 (patch)
tree51d7dd065030a126186eca0d3836dbc6e275de25 /recipes-bsp
parent6519e7e281237b0a9752c187b037f31273aa5f37 (diff)
u-boot-toradex: uprev to 2024.04, drop imx8m{m|p}
Forward port Apalis iMX8, Colibri iMX8X to NXP downstream U-Boot release 6.6.23-2.0.0, based on upstream U-Boot 2024.04 and uprev PREFERRED_VERSION for the two machines accordingly. The Verdin iMX8M{M|P} are now feature complete in upstream U-Boot. No forward porting done for these boards. Change the COMPATIBLE_MACHINE to only Apalis iMX8, Colibri iMX8X and drop additional deploy code only applicable for the Verdins. Related-to: ELB-5848 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 5de23ed5a5623fc89f7ed257b4114a52f3d777ad)
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.04.bb50
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2024.04.bb28
2 files changed, 28 insertions, 50 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb b/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
deleted file mode 100644
index 8daab4f..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-SUMMARY = "U-Boot bootloader with support for Toradex i.MX 8 series SoMs"
-HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
-SECTION = "bootloaders"
-LICENSE = "GPL-2.0-or-later"
-LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "bc-native dtc-native flex-native bison-native python3-setuptools-native"
-PROVIDES:append = " u-boot"
-
-require recipes-bsp/u-boot/u-boot.inc
-
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "a1eb18d157f49d6d1d5a4a11c0377d40f8542467"
-SRCREV:use-head-next = "${AUTOREV}"
-SRCBRANCH = "toradex_imx_lf_v2022.04"
-
-S = "${WORKDIR}/git"
-B = "${WORKDIR}/build"
-
-BOOT_TOOLS = "imx-boot-tools"
-
-inherit toradex-u-boot-localversion
-# build imx-boot from within U-Boot
-inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
-
-UBOOT_INITIAL_ENV = "u-boot-initial-env"
-
-COMPATIBLE_MACHINE = "(mx8-generic-bsp)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-do_deploy:append:mx8m-generic-bsp() {
- # Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- install -d ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}/${UBOOT_DTB_NAME}-${type}
- install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
- fi
- done
- unset j
- done
- unset i
- fi
-}
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2024.04.bb b/recipes-bsp/u-boot/u-boot-toradex_2024.04.bb
new file mode 100644
index 0000000..d68cd7b
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex_2024.04.bb
@@ -0,0 +1,28 @@
+SUMMARY = "U-Boot bootloader with support for Toradex i.MX 8 series SoMs"
+HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
+SECTION = "bootloaders"
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "bc-native dtc-native flex-native bison-native python3-setuptools-native"
+PROVIDES:append = " u-boot"
+
+require recipes-bsp/u-boot/u-boot.inc
+
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
+SRCREV = "22d100d163d841f261eecd76e01025b9782f6378"
+SRCREV:use-head-next = "${AUTOREV}"
+SRCBRANCH = "toradex_imx_lf_v2024.04"
+
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+BOOT_TOOLS = "imx-boot-tools"
+
+inherit toradex-u-boot-localversion
+# build imx-boot from within U-Boot
+inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
+
+UBOOT_INITIAL_ENV = "u-boot-initial-env"
+
+COMPATIBLE_MACHINE = "(colibri-imx8x|apalis-imx8)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"