summaryrefslogtreecommitdiff
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-08-10 19:37:50 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-08-20 18:27:45 +0200
commit2d79d5d46ed74b2d8fb720f6bd29723ae42d226c (patch)
treea72ee36e847273f5a6ca5c397bad1c8b1b023690 /recipes-multimedia
parent24fce804dddda42171b1fb1804843cf5b3031d9e (diff)
gstreamer: update to 1.16.imx 5.4.24_2.1.0 bsp
Related-to: ELB-2758 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch60
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch34
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bbappend6
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend3
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bbappend2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bbappend2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bbappend2
9 files changed, 106 insertions, 7 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
new file mode 100644
index 0000000..7ce7d12
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
@@ -0,0 +1,60 @@
+From b54bb00e2bf3344ff740b5a642dc1a7c70b3d76f Mon Sep 17 00:00:00 2001
+From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
+Date: Sun, 26 Jan 2020 10:45:28 +0000
+Subject: [PATCH] ext/wayland: fix meson build in nxp fork
+
+- Add Wayland protocols, which are not enabled in upstream
+- Add missing compilation unit, which in NXP-specific
+
+Upstream-Status: Pending
+
+Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
+---
+ ext/wayland/meson.build | 24 ++++++++++++++++++++++++
+ 1 file changed, 24 insertions(+)
+
+diff --git a/ext/wayland/meson.build b/ext/wayland/meson.build
+index 3c377eefb..5ef082dac 100644
+--- a/ext/wayland/meson.build
++++ b/ext/wayland/meson.build
+@@ -8,6 +8,11 @@ wl_sources = [
+ 'wllinuxdmabuf.c'
+ ]
+
++imx_wl_sources = [
++ 'wlutils.c',
++]
++wl_sources += imx_wl_sources
++
+ libdrm_dep = dependency('libdrm', version: '>= 2.4.55', required:get_option('wayland'))
+
+ if use_wayland
+@@ -21,6 +26,25 @@ if use_wayland
+ 'fullscreen-shell-unstable-v1-protocol.c', 'fullscreen-shell-unstable-v1-client-protocol.h'],
+ ['/stable/xdg-shell/xdg-shell.xml', 'xdg-shell-protocol.c', 'xdg-shell-client-protocol.h'],
+ ]
++
++ imx_protocol_defs = [
++ [
++ '/unstable/alpha-compositing/alpha-compositing-unstable-v1.xml',
++ 'alpha-compositing-unstable-v1-protocol.c',
++ 'alpha-compositing-unstable-v1-client-protocol.h'
++ ],
++ ['/unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml',
++ 'hdr10-metadata-unstable-v1-protocol.c',
++ 'hdr10-metadata-unstable-v1-client-protocol.h'
++ ],
++ [
++ '/unstable/linux-explicit-synchronization/linux-explicit-synchronization-unstable-v1.xml',
++ 'linux-explicit-synchronization-unstable-v1-protocol.c',
++ 'linux-explicit-synchronization-unstable-v1-client-protocol.h'
++ ],
++ ]
++ protocol_defs += imx_protocol_defs
++
+ protocols_files = []
+
+ foreach protodef: protocol_defs
+--
+2.20.1
+
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch
new file mode 100644
index 0000000..df54c4d
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch
@@ -0,0 +1,34 @@
+From 8f8204b21edbecec159af2a97e247da9326ae9b7 Mon Sep 17 00:00:00 2001
+From: Andrey Zhizhikin <andrey.z@gmail.com>
+Date: Sat, 9 May 2020 19:56:51 +0000
+Subject: [PATCH] opencv: allow compilation against 4.3.x
+
+Backport upstream commit 4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef to NXP
+fork of gstreamer1.0-plugins-bad.
+
+Original commit link:
+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/commit/4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef
+
+Upstream-Status: Backport [4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef]
+
+Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
+---
+ ext/opencv/meson.build | 2 +-
+ 1 file changed, 1insertions(+), 1 deletions(-)
+
+diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
+index f38b55dfe..6a7836094 100644
+--- a/ext/opencv/meson.build
++++ b/ext/opencv/meson.build
+@@ -65,7 +65,7 @@ if opencv_found
+ endif
+ endforeach
+ else
+- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.2.0'], required : false)
++ opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.4.0'], required : false)
+ opencv_found = opencv_dep.found()
+ if opencv_found
+ foreach h : libopencv4_headers
+--
+2.20.1
+
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend
deleted file mode 100644
index a6d37f8..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-SRCBRANCH = "MM_04.05.02_1911_L4.14.98"
-SRCREV = "9fc1ada651093b37675d30a2794044d06bcacdc8"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bbappend
new file mode 100644
index 0000000..53d13c1
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer1.0-plugins-bad:"
+SRCBRANCH = "MM_04.05.05_2005_L5.4.24"
+SRCREV = "2fdaef1839ebfef7ea3bc8c1c59463a9ef0ae19a"
+SRC_URI_remove = " \
+ file://0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch \
+" \ No newline at end of file
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend
deleted file mode 100644
index 6c10a8d..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer1.0-plugins-base:"
-SRCBRANCH = "MM_04.05.02_1911_L4.14.98"
-SRCREV = "5e8cc757e4fec72ee007ac12fab2d1333fce1dc9"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bbappend
new file mode 100644
index 0000000..ac10f64
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bbappend
@@ -0,0 +1,2 @@
+SRCBRANCH = "MM_04.05.05_2005_L5.4.24"
+SRCREV = "cad00a3c4318c787c9661990e8f9328e4a69a329"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend
deleted file mode 100644
index 3235493..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-SRCBRANCH = "MM_04.05.02_1911_L4.14.98"
-SRCREV = "604bc57870878c76a6735db74ff7f15c1802ba4c"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bbappend
new file mode 100644
index 0000000..bdbd1f4
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bbappend
@@ -0,0 +1,2 @@
+SRCBRANCH = "MM_04.05.05_2005_L5.4.24"
+SRCREV = "fc6d8ccf3bd775517fafb1ce1d9224312d2812d8"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bbappend
new file mode 100644
index 0000000..de3f1a7
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bbappend
@@ -0,0 +1,2 @@
+SRCBRANCH = "MM_04.05.05_2005_L5.4.24"
+SRCREV = "beca1b382febc2ba38a21fcb8f5092209773eb7f"