summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
index fc22b5f..3b51cbb 100644
--- a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
+++ b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
@@ -1,6 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
require recipes-kernel/linux/linux-imx.inc
+python () {
+ # Explicitly set KERNEL_FEATURES to empty, since we dont support KMETA yet.
+ kernel_features = d.getVar('KERNEL_FEATURES')
+ if kernel_features:
+ d.setVar('KERNEL_FEATURES', '')
+}
+
SUMMARY = "Linux kernel for Toradex Freescale i.MX based modules"
SUMMARY_append_preempt-rt = "Real-Time Linux kernel for Toradex Freescale i.MX based modules"