summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_2020.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2020.07.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
index 10b4e58..fd6359e 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
@@ -9,6 +9,7 @@ DEPENDS += "bc-native dtc-native"
BOOT_TOOLS = "imx-boot-tools"
+PADDING_DIR = "${B}"
nand_padding () {
# pad the end of U-Boot with 0x00 up to the the end of the CSF area
@@ -17,11 +18,11 @@ nand_padding () {
#objcopy -I binary -O binary --pad-to $PAD_END u-boot.imx u-boot.imx.zero-padded
# assume that the above never need more than 10k of padding and skip the
# shell magic to get a correct size.
- dd bs=10k count=1 if=/dev/zero | cat u-boot.imx - > u-boot.imx.zero-padded
+ dd bs=10k count=1 if=/dev/zero | cat ${PADDING_DIR}/u-boot.imx - > ${PADDING_DIR}/u-boot.imx.zero-padded
# U-Boot is flashed 1k into a NAND block, create a binary which prepends
# U-boot with 1k of zeros to ease flashing
- dd bs=1024 count=1 if=/dev/zero | cat - u-boot.imx.zero-padded > u-boot-nand.imx
+ dd bs=1024 count=1 if=/dev/zero | cat - ${PADDING_DIR}/u-boot.imx.zero-padded > ${PADDING_DIR}/u-boot-nand.imx
}
do_compile_append_colibri-imx6ull () {