summaryrefslogtreecommitdiff
path: root/qt5-layer
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-01-13 14:46:45 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2023-01-25 16:21:24 +0100
commit823a67325ce22c10feb711fc407ef869cf0fa86c (patch)
tree6f9855a77eb86415932fb49a33eebffd07d3bb86 /qt5-layer
parentfcceceb8ca66a0768c878fa9d386f81aaa69a53a (diff)
qtbase-conf: import from meta-arago
Might require rework to apply to ti only. Related-to: ELB-4978 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'qt5-layer')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase-conf/eglfs_kms_cfg.json14
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase-conf/qt_env.sh13
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase-conf/ti33x/qt_env.sh14
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase-conf_1.0.bb20
4 files changed, 61 insertions, 0 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase-conf/eglfs_kms_cfg.json b/qt5-layer/recipes-qt/qt5/qtbase-conf/eglfs_kms_cfg.json
new file mode 100644
index 0000000..ac19b8e
--- /dev/null
+++ b/qt5-layer/recipes-qt/qt5/qtbase-conf/eglfs_kms_cfg.json
@@ -0,0 +1,14 @@
+{
+ "device": "/dev/dri/card0",
+ "hwcursor": false,
+ "pbuffers": true,
+ "outputs": [
+ {
+ "name": "VGA1",
+ "mode": "off"
+ },
+ {
+ "name": "HDMI1"
+ }
+ ]
+}
diff --git a/qt5-layer/recipes-qt/qt5/qtbase-conf/qt_env.sh b/qt5-layer/recipes-qt/qt5/qtbase-conf/qt_env.sh
new file mode 100644
index 0000000..c79ccd4
--- /dev/null
+++ b/qt5-layer/recipes-qt/qt5/qtbase-conf/qt_env.sh
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+### QT Environment Variables ###
+export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+export QT_QPA_EGLFS_KMS_CONFIG=/etc/qt5/eglfs_kms_cfg.json
+export QT_QPA_EGLFS_INTEGRATION=eglfs_kms
+export QT_QPA_EGLFS_ALWAYS_SET_MODE=1
+export QT_WAYLAND_SHELL_INTEGRATION=xdg-shell
+
+# SECCOMP-BPF Sandbox does not work due to unexpected FUTEX_UNLOCK_PI call
+# from the pthread implementation. Disable this feature temporarily until
+# those issues are resolved.
+export QTWEBENGINE_CHROMIUM_FLAGS="--disable-seccomp-filter-sandbox"
diff --git a/qt5-layer/recipes-qt/qt5/qtbase-conf/ti33x/qt_env.sh b/qt5-layer/recipes-qt/qt5/qtbase-conf/ti33x/qt_env.sh
new file mode 100644
index 0000000..ef49b12
--- /dev/null
+++ b/qt5-layer/recipes-qt/qt5/qtbase-conf/ti33x/qt_env.sh
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+### QT Environment Variables ###
+export QT_QPA_EVDEV_TOUCHSCREEN_PARAMETERS="rotate=180"
+export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+export QT_QPA_EGLFS_KMS_CONFIG=/etc/qt5/eglfs_kms_cfg.json
+export QT_QPA_EGLFS_INTEGRATION=eglfs_kms
+export QT_QPA_EGLFS_ALWAYS_SET_MODE=1
+export QT_WAYLAND_SHELL_INTEGRATION=xdg-shell
+
+# SECCOMP-BPF Sandbox does not work due to unexpected FUTEX_UNLOCK_PI call
+# from the pthread implementation. Disable this feature temporarily until
+# those issues are resolved.
+export QTWEBENGINE_CHROMIUM_FLAGS="--disable-seccomp-filter-sandbox"
diff --git a/qt5-layer/recipes-qt/qt5/qtbase-conf_1.0.bb b/qt5-layer/recipes-qt/qt5/qtbase-conf_1.0.bb
new file mode 100644
index 0000000..5c2974e
--- /dev/null
+++ b/qt5-layer/recipes-qt/qt5/qtbase-conf_1.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "qtbase configuration files"
+HOMEPAGE = "http://www.qt.io/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRC_URI = "file://qt_env.sh \
+ file://eglfs_kms_cfg.json \
+ "
+
+# Add custom Arago qtbase Environment script and eglfs_kms configuration file
+do_install () {
+ install -d ${D}${sysconfdir}/profile.d
+ install -m 0644 ${WORKDIR}/qt_env.sh ${D}${sysconfdir}/profile.d/
+ install -d ${D}${sysconfdir}/qt5
+ install -m 0644 ${WORKDIR}/eglfs_kms_cfg.json ${D}${sysconfdir}/qt5/
+}
+
+FILES_${PN} += "${sysconfdir}/profile.d/* ${sysconfdir}/qt5/*"