summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-06-30 13:52:07 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-07-25 17:21:41 +0200
commit4c40178f77339a38712b4d37fdc5ef188929cbf3 (patch)
tree75a2e354b698ad4945eef54c9db9f3d1e885e64b /recipes-bsp
parent9d76eab841cd8ae812adde0387eff043a2832971 (diff)
u-boot: updated to the toradex_ti-u-boot-2023.04 branch
- Update to the toradex_ti-u-boot-2023.04 branch, based on the ti-u-boot-2023.04. - This includes/requires the move to use binman to assemble the binaries used for boot. - With the change to binman the R5 SPL is now built from one OE machine only, not one machine per SoC flavour (GP, HS-FS, HS). - With binman we also change the name for the tiboot3* files to match the machine they are built form, not claiming to be the evm. E.g. tiboot3-am62x-hs-fs-verdin.bin. - With the binman and HS-FS we need to package the kernel also as a fitimage to prevent a build error in U-Boot, however we keep using Image.gz - Drop the '-staging' from the recipe name. Related-to: ELB-5238 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb (renamed from recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb)39
1 files changed, 34 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index 6cdca41..a5a9ce0 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -5,15 +5,13 @@ LICENSE = "GPL-2.0-or-later"
require recipes-bsp/u-boot/u-boot-ti.inc
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
-
-DEPENDS += "flex-native bison-native"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "1758570639a6bd53e968808a624db532ad905c4b"
+SRCREV = "2ddf78e50e65686b8d14e76908d534ef66b9f83d"
SRCREV:use-head-next = "${AUTOREV}"
-SRCBRANCH = "toradex_ti-u-boot-2021.01_bringup"
+SRCBRANCH = "toradex_ti-u-boot-2023.04"
B = "${WORKDIR}/build"
S = "${WORKDIR}/git"
@@ -32,6 +30,37 @@ DEPLOY_INITIAL_ENV:k3r5 = ":"
do_deploy:append () {
${DEPLOY_INITIAL_ENV}
}
+do_deploy:append:k3r5 () {
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ i=$(expr $i + 1);
+ for type in ${UBOOT_CONFIG}; do
+ j=$(expr $j + 1);
+ if [ $j -eq $i ]
+ then
+ for f in ${B}/${config}/tiboot3-*.bin; do
+ if [ -f "$f" ]; then
+ install -m 644 $f ${DEPLOYDIR}/
+ fi
+ done
+
+ for f in ${B}/${config}/sysfw*.itb; do
+ if [ -f "$f" ]; then
+ install -m 644 $f ${DEPLOYDIR}/
+ fi
+ done
+ fi
+ done
+ unset j
+ done
+ unset i
+ else
+ if ! [ -f ${B}/${UBOOT_BINARY} ]; then
+ ln -s spl/${UBOOT_BINARY} ${B}/${UBOOT_BINARY}
+ fi
+ fi
+}
# build the k3r5 spl also for DFU
do_compile:append:k3r5 () {