summaryrefslogtreecommitdiff
path: root/recipes-core/systemd/timestamp-service.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/systemd/timestamp-service.bb')
-rw-r--r--recipes-core/systemd/timestamp-service.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-core/systemd/timestamp-service.bb b/recipes-core/systemd/timestamp-service.bb
index 914e610..676a153 100644
--- a/recipes-core/systemd/timestamp-service.bb
+++ b/recipes-core/systemd/timestamp-service.bb
@@ -8,13 +8,15 @@ SRC_URI = "file://timestamp.service \
file://load-timestamp.sh \
"
+S = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
do_install () {
install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/load-timestamp.sh ${D}/${bindir}
+ install -m 0755 ${S}/load-timestamp.sh ${D}/${bindir}
install -d ${D}/${base_libdir}/systemd/system
- install -m 0644 ${WORKDIR}/timestamp.service ${D}/${base_libdir}/systemd/system/
+ install -m 0644 ${S}/timestamp.service ${D}/${base_libdir}/systemd/system/
}
SYSTEMD_PACKAGES = "${PN}"