summaryrefslogtreecommitdiff
path: root/recipes-core/systemd/timestamp-service.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 11:30:33 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 17:32:46 +0200
commit48fb6ae80a1aa5765ff420877219d8eb35b11396 (patch)
tree0e422642fa0d25006184f51dd9fc4b9f0b0c92b2 /recipes-core/systemd/timestamp-service.bb
parent9f699aed67850db573ee3c51de7110fd235084c1 (diff)
recipes: cope with moved directory for unpackHEADmaster
OE master (styhead) no longer unpacks in ${WORKDIR} but rather does it in path defined by the new variable UNPACKDIR. Additionally '${S} = ${WORKDIR}' is no longer allowed and results in a parse time error. Cope with the change so that the layer builds against scarthgap and styhead. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-core/systemd/timestamp-service.bb')
-rw-r--r--recipes-core/systemd/timestamp-service.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-core/systemd/timestamp-service.bb b/recipes-core/systemd/timestamp-service.bb
index 914e610..676a153 100644
--- a/recipes-core/systemd/timestamp-service.bb
+++ b/recipes-core/systemd/timestamp-service.bb
@@ -8,13 +8,15 @@ SRC_URI = "file://timestamp.service \
file://load-timestamp.sh \
"
+S = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
do_install () {
install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/load-timestamp.sh ${D}/${bindir}
+ install -m 0755 ${S}/load-timestamp.sh ${D}/${bindir}
install -d ${D}/${base_libdir}/systemd/system
- install -m 0644 ${WORKDIR}/timestamp.service ${D}/${base_libdir}/systemd/system/
+ install -m 0644 ${S}/timestamp.service ${D}/${base_libdir}/systemd/system/
}
SYSTEMD_PACKAGES = "${PN}"